AccuWeather.com Degraded Performance
Incident Report for AccuWeather
Resolved
The issue causing degraded performance on AccuWeather.com has been resolved. Services have been restored and we are continuing to monitor.

All other services continued to work as expected. We sincerely apologize for any inconvenience caused by this incident and appreciate your patience through this process.
Posted Dec 16, 2019 - 15:44 EST
Investigating
We are currently investigating an issue causing degraded performance on AccuWeather.com. During this time, some customers may experience latency on the AccuWeather.com site and/or content loading errors. We apologize for any impact this is causing and are working to resolve this issue.
Posted Dec 16, 2019 - 15:24 EST